不具合発生中・・・(@_@) 取り敢えず記事は見られる様にしました!!写真は少しずつ復旧します(^_^;)
Cocoon

取り合ええず、なんとかなった!

ちょっと前から、なんだか挙動不審だったWordPress。
何が悪いんだかよく分からなくて、やりかけては諦めて放置を繰り返して
今回やっとなんとかなりました。

一応覚え書き。


記事を書こうとすると、表示がなんだか変。
それでもちゃんと投稿出来るし、ブログの表示は大丈夫だけど
投稿画面の表示がずれちゃってて、使いづらくてしょうがない。

別サイトが正常なので何が違うかを考えたら、cocoonのバージョンが古いままだったので
もしかしたらcocoonのバージョンを古いものに戻したらいいかも?と思い
試してみました。



画面真っ白!(◎_◎;)

マジかぁ・・・どうしよう・・・と焦ったけど
一度削除すればいいと、どこかのサイトに書いてあったのを思い出して
cocoonを一旦削除。

無事、管理画面が表示されるようになりました。
ホッ。

この時、cocoonは削除してしまったので、別のテーマで表示されてました。

もしかしたら、WordPressのバージョンアップをしたら直るのかも?と思い
やってみる事に。

でも、

WordPress 5.2.1 は PHP バージョン5.6.20以上が必要なため、更新できません。現在の PHP バージョンは5.3.29です。

PHPは、サーバー側で確認すると7.2になっている。
取り敢えず、7.4が使えるようになってたので、この際7.4に変更しておく。

あれこれググって↓コチラを参考に.htaccessを書き換え。

するとさっきののメッセージは出なくなったけど、別のメッセージが出るように・・・。

Warning: Use of undefined constant ture – assumed ‘ture’ (this will throw an Error in a future version of PHP) in /virtual/ponkichi/public_html/wp-config.php on line 88

Warning: Cannot modify header information – headers already sent by (output started at /virtual/ponkichi/public_html/wp-config.php:88) in /virtual/ponkichi/public_html/wp-admin/includes/misc.php on line 1198

もう、言ってる事が全然分からないので
とりあえず、cocoonの最新バージョンをインストール。

Cocoonの表示がされるようになったけど、相変わらず表示がおかしい(T_T)

73だから?と思って

74に変更したら↓コチラが表示された。

<?php
/**
 * Updates network administration panel.
 *
 * @package WordPress
 * @subpackage Multisite
 * @since 3.1.0
 */
/** Load WordPress Administration Bootstrap */
require_once( dirname( __FILE__ ) . ‘/admin.php’ );
require( ABSPATH . ‘wp-admin/update-core.php’ );

またまたググって↓このように書き換え。

/* 追加した設定マルチサイト */
define(‘WP_ALLOW_MULTISITE’, ‘ture’);

tureを’’で囲ってアップロードしたらエラーは出なくなりました。

結局、もうなんだか分からなくなったので
「cocoon設定」>「エディター」のエディタースタイルの所のチェックを外し
テーマスタイルを反映させないで使う事にしました。

ところで、テーマ入れ直したのに、それまで使ってた設定がそのまま残ってる!
なんで?(^_^;)
不思議だけどま、いいか(笑)

と思ったけど、やっぱり腑に落ちないので
何とかしようとあちこちググっていたら

cocoonのフォーラムに↓コチラを発見。

何度も検索したのに、その時は見つからなかったけど
これを見つけた時に「まさにこれだ!!」と。

作者のわいらひさんのコメントにあるように
私の使ってるWordPressのバージョンも、5.1.4でした。

そして、WordPressをバージョンアップしたら
無事、表示が戻りました!!

良かったーーー(T_T)

これで、やっと落ち着いてブログが書ける〜と思ったのも束の間
今度は画像をアップロードすると、リサイズされてしまう現象が・・・(T_T)

色々調べてみたら、↓コチラのように3つの解決方法があることを知りました。

取り敢えず、いちばん簡単そうなfunction.phpに書き込むのをやってみました。

add_filter( 'big_image_size_threshold', '__return_false' );

無事、リサイズされずにアップロードされました(嬉)

実は、これを選んだ理由は、プラグインをインストールしようとすると
また、例のメッセージが表示されてしまったのです。

↓コレ

WordPress 5.2.1 は PHP バージョン5.6.20以上が必要なため、更新できません。現在の PHP バージョンは5.3.29です。

あぁ、これはアレだね。
同じように、73cgiにしたらいいのね〜と思いつつ
サーバ〜のPHPが7.4なので74cgiと書き込んでアップロードしたら
あかんかったやつで(^_^;)
仕方ないので元に戻して、function.phpに書き加える事にしたのです。

取り敢えずここまで。

なんだか色々やりすぎて、結局何かよく分からないけど
一応、なんとか使えるようになったという話でした(^_^;)

コメント